A Simple FRAMESET Example

Frames: An Introduction


Frame ALERT!

This document is designed to be viewed using Netscape 2.0's Frame features. If you are seeing this message, you are using a frame challenged browser.

A Frame-capable browser can be gotten from Netscape Communications.


A Simple TABLE Example

CELL1 CELL2
CELL3
CELL4
CELL5


Frame Implementation Notes

FRAMES: IMPLEMENTATION

ч ЬФПН ДПЛХНЕОФЕ ПРЙУБОЩ ОЕЛПФПТЩЕ ЧБЦОЩЕ ЫФХЮЛЙ, РТПВМЕНЩ РТЙ УПЪДБОЙЙ ТБНПЛ Й РХФЙ ЙИ ТЕЫЕОЙС.

нпзхф мй тбнлй вщфш чмпцеощнй?

фЬЗ FRAMESET ЧРПМОЕ НПЦЕФ ВЩФШ ЧМПЦЕОЩН, ЛБЛ ЧРТПЮЕН Й ОБРЙУБОП Ч пРЙУБОЙЙ УЙОФБЛУЙУБ. оП ФБЛБС УФТХЛФХТБ Ч ПУОПЧОПН УФБОПЧЙФУС РМПУЛПК РЕТЕД ЧЩЧПДПН ОБ ЬЛТБО. (юФП ПОЙ ИПФЕМЙ ЬФЙН УЛБЪБФШ?) б ЧПФ ВПМЕЕ ЙОФЕТЕУОЩК ЧПРТПУ: НПЦЕФ МЙ FRAME УПДЕТЦБФШ ДПЛХНЕОФ, СЧМСАЭЙКУС Ч УЧПА ПЮЕТЕДШ FRAMESET-ПН? чЛТБФГЕ НПЦОП ПФЧЕФЙФШ ФБЛ: дБ. лПОЕЮОП, FRAMESET-Щ ДПМЦОЩ ВЩФШ ЧМПЦЕООЩНЙ, ПУПВЕООП ЛПЗДБ УЧСЪШ Ч ПДОПН ПЛОЕ ДПМЦОБ РЕТЕЪБЗТХЦБФШ ОЕУЛПМШЛП ДТХЗЙИ ПЛПО.

юфп улбцефе ъб веулпоеюоха ттелхтуйа?

чПЪНПЦОП УПЪДБФШ FRAMESET, ЛПФПТЩК ВХДЕФ ВЕУЛПОЕЮОП ТЕЛХТУЙЧОП ЪБЗТХЦБФШ ПДЙО Й ФПФ ЦЕ FRAMESET ДП ФЕИ РПТ, РПЛБ ОЕ ЛПОЮЙФУС РБНСФШ. рПУНПФТЙФЕ ОБ ЬФПФ РТЙНЕТ:

<FRAMESET rows="50%,50%">

< FRAME src=parents_url>

<FRAME>

</FRAMESET>

пЮЕЧЙДОП ЮФП ПО ОЕИПТПЫ, ОП РТПФЙЧ РПДПВОПЗП ЙНЕЕФУС ЪБЭЙФБ. мАВБС ТБНЛБ, ЛПФПТБС РЩФБЕФУС РТЙУЧПЙФШ SRC URL ФБЛПК ЦЕ ЛБЛ Х МАВПЗП ЙЪ РТЕДЛПЧ, УЮЙФБЕФУС ЧПЧУЕ ОЕ ЙНЕАЭЕК SRC URL (Й ПВЩЮОП УФБОПЧЙФУС РХУФПК ТБНЛПК). иПФС ЬФП ОЕ РПНПЗБЕФ ПФ ЧУЕИ ЙДЙПФЙЮЕУЛЙИ ДПЛХНЕОФПЧ, ФЕН ОЕ НЕОЕЕ ЙЪТСДОП ХНЕОШЫБЕФ ЙИ ЛПМЙЮЕУФЧП.

Corporate Sales: 415/937-2555; Personal Sales: 415/937-3777; Federal Sales: 415/937-3678
If you have any questions, please visit Customer Service.

Copyright © 1996 Netscape Communications Corporation

бЧФПТЙЪПЧБОЩК РЕТЕЧПД бОФПОБ мПВБУФПЧБ, ХЦ ЙЪЧЙОСКФЕ, ЕУМЙ ЮЕЗП ОЕ ФБЛ...
[оБЪБД ЛП ЧУСЛПК ПФОПУСЭЕКУС Л Web ДПЛХНЕОФБГЙЙ]


Frame Basics

FRAMES - SYNTAX

тБНЛЙ УПЪДБАФУС РТЙ РПНПЭЙ ФТЕИ ЫФХЮЕЛ: ФЬЗБ FRAMESET, ФЬЗБ FRAME, Й Frame-ДПЛХНЕОФПЧ.

FRAME DOCUMENT

дПЛХНЕОФ У ТБНЛБНЙ ЙНЕЕФ УФТХЛФХТХ ПЮЕОШ РПИПЦХА ОБ ПВЩЮОЩК HTML ДПЛХНЕОФ, ЪБ ЙУЛМАЮЕОЙЕН ФПЗП, ЮФП ЛПОФЕКОЕТ BODY ЪБНЕОЕО ОБ ЛПОФЕКОЕТ FRAMESET, ПРЙУЩЧБАЭЙК HTML РПД-ДПЛХНЕОФЩ, ЙМЙ тБНЛЙ, УПУФБЧМСАЭЙЕ ДПЛХНЕОФ.

<HTML>

<HEAD>
</HEAD>

<FRAMESET>
</FRAMESET>

</HTML>

FRAME SYNTAX

уЙОФБЛУЙУ тБНПЛ РПИПЦ ОБ УЙУОФБЛУЙУ, ЙУРПМШЪХЕНЩК ДМС УПЪДБОЙС ФБВМЙГ, Й ВЩМ УРЕГЙБМШОП ТБЪТБВПФБО ДМС ВЩУФТПК ПВТБВПФЛЙ НПФПТЮЙЛБНЙ (engines) Internet-ЛМЙЕОФПЧ.

<FRAMESET>

ьФП ЗМБЧОЩК ЛПОФЕКОЕТ ДМС тБНЛЙ, ЙНЕАЭЙК 2 БФФТЙВХФБ: ROWS Й COLS. дПЛХНЕОФ-Ч-ТБНЛЕ ОЕ ЙНЕЕФ BODY Й ФЬЗЙ, ЛПФПТЩЕ ПВЩЮОП РПНЕЭБАФУС Ч BODY ОЕ НПЗХФ ЧУФТЕЮБФШУС ДП ФЬЗБ FRAMESET, ЙОБЮЕ FRAMESET ВХДЕФ РТПЙЗОПТЙТПЧБО. фЬЗ FRAMESET ДПМЦЕО ЙНЕФШ ЪБЛТЩЧБАЭЙК ФЬЗ, Б ЧОХФТЙ FRAMESET-Б ЧЩ НПЦЕФЕ ХРПФТЕВМСФШ ФПМШЛП ДТХЗЙЕ, ЧМПЦЕОЩЕ FRAMESET-Щ Й ФЬЗЙ FRAME ЙМЙ NOFRAME.

ROWS="УРЙУПЛ_ЧЩУПФ_ТСДПЧ"
ROWS БФТЙВХФ Ч ЛБЮЕУФЧЕ ЪОБЮЕОЙС ЙНЕЕФ УРЙУПЛ ТБЪДЕМЕООЩИ ЪБРСФЩНЙ ЪОБЮЕОЙК. ьФЙ ЪОБЮЕОЙС НПЗХФ ВЩФШ БВУПМАФОЩНЙ ЪОБЮЕОЙСНЙ Ч РЙЛУЕМБИ, РТПГЕОФБНЙ НЕЦДХ 1 Й 100, ЙМЙ ПФОПУЙФЕМШОЩНЙ НБУЫФБВЙТХАЭЙНЙ ЪОБЮЕОЙСНЙ. лПМЙЮЕУФЧП ЪОБЮЕОЙК ДПМЦОП УППФЧЕФУФЧПЧБФШ ЛПМЙЮЕУФЧХ ТСДПЧ Ч FRAMESET-Е. фБЛ ЛБЛ ПВЭБС ЧЩУПФБ ЧУЕИ ТСДПЧ ДПМЦОБ ТБЧОСФШУС ЧЩУПФЕ ПЛОБ, ЧЩУПФЩ ТСДПЧ НПЗХФ ВЩФШ ОПТНБМЙЪПЧБОЩ. рТПРХЭЕОЩК БФТЙВХФ ROWS ЙОФЕТРТЕФЙТХЕФУС ЛБЛ ЕДЙОУФЧЕООЩК ТСД, ПФНБУЫФБВЙТПЧБОЩК ФБЛ, ЮФПВЩ ЪБРПМОЙФШ ПЛОП.
уЙОФБЛУЙУ УРЙУЛБ БТЗХНЕОФПЧ.
ЪОБЮЕОЙЕ
рТПУФП ЮЙУМП РТЕДРПМБЗЕФУС ЪБДБАЭЙН ЖЙЛУЙТПЧБОЩК ТБЪНЕТ Ч РЙЛУЕМБИ. ьФП ОБЙВПМЕЕ ПРБУОЩК ФЙР ЪОБЮЕОЙС, ФБЛ ЛБЛ ТБЪНЕТЩ ПЛОБ РТПЗТБННЩ РТПУНПФТБ НПЗХФ ЧБТШЙТПЧБФШУС Й ЧБТШЙТХАФУС Ч ЪОБЮЙФЕМШОЩИ РТЕДЕМБИ. еУМЙ ЙУРПМШЪХЕФУС ФПЮОПЕ ЪОБЮЕОЙЕ Ч РЙЛУЕМБИ, РПЮФЙ ЧУЕЗДБ ЦЕМБФЕМШОП ЙУРПМШЪПЧБФШ ЧНЕУФЕ У ОЙН ПДОП ЙМЙ ОЕУЛПМШЛП ПФОПУЙФЕМШОЩИ ЪОБЮЕОЙК, ПРЙУБОЩИ ОЙЦЕ. йОБЮЕ РТПЗТБННБ РТПУНПФТБ НПЦЕФ ЙЪНЕОЙФШ ЧБЫЕ ЪОБЮЕОЙЕ, ЮФПВЩ ДПВЙФШУС 100%-ЗП ЪБРПМОЕОЙС УЧПЕЗП ПЛОБ.
ЪОБЮЕОЙЕ%
ьФП РТПУФПЕ ЪОБЮЕОЙЕ Ч РТПГЕОФБИ ПФ 1 ДП 100. еУМЙ ПВЭБС УХННБ РТПГЕОФПЧ РПМХЮБЕФУС ВПМШЫЕ 100, ЧУЕ ПОЙ НБУЫФБВЙТХАФУС Ч УФПТПОХ ХНЕОШЫЕОЙС. еУМЙ ПВЭБС УХННБ НЕОШЫЕ 100, Й ЙНЕАФУС ТБНЛЙ У ПФОПУЙФЕМШОЩН ТБЪНЕТПН, ЙЪМЙЫОЕЕ НЕУФП ВХДЕФ ПФДБОП ЙН. еУМЙ ЦЕ ФБЛПЧЩИ ОЕ ЙНЕЕФУС, ЧУЕ РТПГЕОФЩ ВХДХФ ХЧЕМЙЮЙОЩ, ФБЛЙН ПВТБЪПН, ЮФПВЩ Ч УХННЕ УПУФБЧМСФШ 100%.
ЪОБЮЕОЙЕ*
ъОБЮЕОЙЕ ОЕ СЧМСЕФУС ПВСЪБФЕМШОЩН. рТПУФП '*' ПЪОБЮБЕФ ТБНЛХ "ПФОПУЙФЕМШОПЗП ТБЪНЕТБ" Й ЙОФЕТРТЕФЙТХЕФУС ЛБЛ РТПУШВБ ДБФШ ТБНЛЕ ЧУЕ ПУФБЧЫЕЕУС НЕУФП. еУМЙ ЙНЕЕФУС ОЕУЛПМШЛП ТБНПЛ ПФОПУЙФЕМШОПЗП ТБЪНЕТБ, ПУФБЧЫЕЕУС НЕУФП ТБУРТЕДЕМСЕФУС НЕЦДХ ОЙНЙ РПТПЧОХ. еУМЙ РЕТЕД '*' ЧУЕ ЦЕ РТЙУХФУФЧХЕФ ЪОБЮЕОЙЕ, УППФЧЕФУФЧХАЭБС ТБНЛБ РПМХЮБЕФ Ч ЪОБЮЕОЙЕ-ТБЪ ВПМШЫЕ НЕУФБ, ЮЕН ПУФБМШОЩЕ. оБРТЙНЕТ "2*,*" ДБУФ 2/3 НЕУФБ РЕТЧПК ТБНЛЕ Й 1/3 ЧФПТПК.
рТЙНЕТ 3-И ТСДПЧ, ЗДЕ РЕТЧЩК Й РПУМЕДОЙК НЕОШЫЕ УТЕДОЕЗП:
<FRAMESET ROWS="20%,60%,20%">

рТЙНЕТ 3-И ТСДПЧ, ЗДЕ РЕТЧЩК Й РПУМЕДОЙК ЙНЕАФ ЖЙЛУЙТПЧБОХА ЧЩУПФХ, Б ПУФБЧЫЕЕУС НЕУФП ПФДБЕФУС УТЕДОЕНХ ТСДХ:
<FRAMESET ROWS="100,*,100">

COLS="УРЙУПЛ_ЫЙТЙО_ЛПМПОПЛ"
х БФТЙВХФБ COLS ЪОБЮЕОЙЕ РТЕДУФБЧМСЕФ УПВПК УРЙУПЛ ЪОБЮЕОЙК ЫЙТЙО ЛПМПОПЛ, ПФЧЕДЕООЩИ ТБНЛБН, У УЙОФБЛУЙУПН РПМОПУФША БОБМПЗЙЮОЩН УЙОФБЛУЙУХ ЪОБЮЕОЙК БФТЙВХФБ ROWS (УН. ЧЩЫЕ).

фЬЗ FRAMESET НПЦЕФ ВЩФШ ЧМПЦЕО ЧОХФТШ ДТХЗПЗП ФЬЗБ FRAMESET. ч ЬФПН УМХЮБЕ ОБВПТ ТБНПЛ РПНЕЭБЕФУС ОБ НЕУФП, ЛПФПТПЕ ПФЧЕМПУШ ВЩ УППФЧЕФУФЧХАЭЕК ТБНЛЕ, ЕУМЙ ВЩ ОБ НЕУФЕ ЧМПЦЕОПЗП FRAMESET ВЩМ ВЩ ПВЩЮОЩК FRAME.
<FRAME>
ьФПФ ФЬЗ ПРТЕДЕМСЕФ ПДОХ ТБНЛХ Ч ОБВПТЕ. пО ЙНЕЕФ 6 ЧПЪНПЦОЩИ БФТЙВХФПЧ: SRC, NAME, MARGINWIDTH, MARGINHEIGHT, SCROLLING, Й NORESIZE. фЬЗ FRAME ОЕ СЧМСЕФУС ЛПОФЕКОЕТПН Й РПЬФПНХ ЕНХ ОЕ ОХЦЕО ЪБЧЕТЫБАЭЙК ФЬЗ.
SRC="url"
ъОБЮЕОЙЕН БФТЙВХФБ SRC СЧМСЕФУС URL ДПЛХНЕОФБ, ЛПФПТЩК ДПМЦЕО РПСЧЙФШУС Ч ДБООПК ТБНЛЕ. FRAMEЩ ВЕЪ БФТЙВХФБ SRC ЙЪПВТБЦБАФУС ЛБЛ РХУФПЕ НЕУФП УППФЧЕФУФЧХАЭЕЗП ТБЪНЕТБ.
NAME="ЙНС_ПЛОБ"
бФТЙВХФ NAME ЙУРПМШЪХЕФУС ДМС РТЙУЧПЕОЙС ЙНЕОЙ ТБНЛЕ, РПУМЕ ЮЕЗП ЕЕ НПЦОП ЙУРПМШЪПЧБФШ ЛБЛ ПЛОП ОБЪОБЮЕОЙС Ч УУЩМЛБИ ЙЪ ДТХЗЙИ ДПЛХНЕОФПЧ (ПВЩЮОП ЙЪ ДТХЗЙИ ТБНПЛ ФПЗП ЦЕ ДПЛХНЕОФБ). бФТЙВХФ NAME НПЦЕФ Й ПРХУЛБФШУС; РП ХНПМЮБОЙА ЧУЕ ПЛОБ ОЕЙНЕОПЧБОЩ.
йНЕОБ ДПМЦОЩ ОБЮЙОБФШУС У ВХЛЧЩ ЙМЙ ГЙЖТЩ.
ч рПЙНЕОПЧБОЩЕ ТБНЛЙ НПЗХФ УУЩМБФШУС ДТХЗЙЕ ДПЛХНЕОФЩ РТЙ РПНПЭЙ ОПЧПЗП БФТЙВХФБ TARGET.
MARGINWIDTH="ЪОБЮЕОЙЕ"
бФТЙВХФ MARGINWIDTH ЙУРПМШЪХЕФУС ЛПЗДБ БЧФПТ ДПЛХНЕОФБ ЦЕМБЕФ РПХРТБЧМСФШ ПФУФХРБНЙ Ч ТБНЛЕ. ъОБЮЕОЙЕ ДМС MARGINWIDTH ЪБДБЕФУС Ч РЙЛУЕМБИ Й ОЕ НПЦЕФ ВЩФШ НЕОШЫЕ 1-Щ ЮФПВЩ ПВЯЕЛФЩ Ч ТБНЛЕ ОЕ НПЗМЙ ЙУРПТФЙФШ ЗТБОЙГЩ ТБНЛЙ, Й ОЕ НПЦЕФ ВЩФШ ВПМШЫЙН, ОЕ ПУФБЧМСАЭЙН НЕУФБ ДМС УПВУФЧЕООП ДПЛХНЕОФБ. бФТЙВХФ ОЕ СЧМСЕФУС ПВСЪБФЕМШОЩН; ЕУМЙ ПО ПРХЭЕО, РТПЗТБННБ РТПУНПФТБ УБНБ ЧЩВЕТЕФ ПРФЙНБМШОПЕ ДМС ОЕЕ ЪОБЮЕОЙЕ.
MARGINHEIGHT="ЪОБЮЕОЙЕ"
бФТЙВХФ MARGINHEIGHT ЙДЕОФЙЮЕО MARGINWIDTH ЪБ ЙУЛМАЮЕОЙЕН ФПЗП, ЮФП ХРТБЧМСЕФ ЧЕТИОЙН Й ОЙЦОЙН ПФУФХРБНЙ ЧНЕУФП МЕЧПЗП Й РТБЧПЗП.
SCROLLING="yes|no|auto"
SCROLLING ЙУРПМШЪХЕФУС ДМС ХРТБЧМЕОЙЕН МЙОЕКЛПК РТПЛТХФЛЙ ТБНЛЙ. Yes ДЕМБЕФ МЙОЕКЛЙ РТПЛТХФЛЙ ЧУЕЗДБ ЧЙДЙНЩНЙ, No - ЧУЕЗДБ ОЕЧЙДЙНЩНЙ, Б Auto РТПУЙФ РТПЗТБННХ РТПУНПФТБ УБНХ ТЕЫБФШ, ЛПЗДБ РПЛБЪЩЧБФШ МЙОЕКЛЙ. бФТЙВХФ SCROLLING ОЕ ПВСЪБФЕМШОЩК; ЕУМЙ ПРХЭЕО РПДТБЪХНЕЧБЕФУС auto.
NORESIZE
бФТЙВХФ NORESIZE ОЕ ЙНЕЕФ ЪОБЮЕОЙС. ьФП РТПУФП ЖМБЗ, РПЛБЪЩЧБАЭЙК ЮФП УНПФТЕМШЭЙЛ ОЕ НПЦЕФ ЙЪНЕОСФШ ТБЪНЕТПЧ ТБНЛЙ. тБЪНЕТЩ ТБНПЛ ПВЩЮОП ЙЪНЕОСАФУС РЕТЕФБУЛЙЧБОЙЕН ЗТБОЙГ ТБНПЛ Ч ОПЧПЕ НЕУФП. ъБНЕФШФЕ, ЮФП ЕУМЙ МАВБС ЙЪ ТБНЛБ ЙНЕАЭЙИ ПВЭХА ЗТБОЙГХ ЙНЕЕФ ЬФПФ ЖМБЗ - ЧУС ЗТБОЙГБ УФБОПЧЙФУС ОЕРЕТЕФБУЛЙЧБЕНПК Й, ЛБЛ УМЕДУФЧЙЕ, ЧУЕ УПУЕДОЙЕ ТБНЛЙ. бФТЙВХФ NORESIZE ОЕ ПВСЪБФЕМШОЩК; ЕУМЙ ПРХЭЕО - ТБНЛБ НПЦЕФ ЙЪНЕОСФШ ТБЪНЕТ.
<NOFRAMES>
ьФП ФЬЗ ДМС МАДЕК, ЦЕМБАЭЙИ УДЕМБФШ БМШФЕТОБФЙЧОПЕ РТЕДУФБЧМЕОЙЕ ДПЛХНЕОФБ ДМС ЛМЙЕОФПЧ ВЕЪ ЧПЪНПЦОПУФЙ ПФПВТБЦЕОЙС ТБНПЛ. лМЙЕОФ У ЧПЪНПЦОПУФСНЙ РТПУФП ЙЗОПТЙТХЕФ ЧУЕ, ЮФП ТБУРПМПЦЕОП НЕЦДХ ПФЛТЩЧБАЭЙН Й ЪБЛТЩЧБАЭЙН ФЬЗБНЙ.

EXAMPLES

ч ЬФПН РТЙНЕТЕ УТБЧОЙЧБЕФУС УЙОФБЛУЙУ FRAME Й TABLE, Б ФБЛЦЕ ДБДЕО ЙУИПДОЩК ФЕЛУФ РТЕДУФБЧМЕООЩИ ОЙЦЕ МБКПХФПЧ.

+----------------------------------------------------------+

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |-----------------------------+

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

+----------------------------|                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |-----------------------------+

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

|                            |                             |

+----------------------------------------------------------+

уДЕМБЕН фБЛ рТЙ рПНПЭЙ фБВМЙГ

<TABLE WIDTH="100%" HEIGHT="100%" BORDER>
<TR><TD ROWSPAN=2>CELL1</TD><TD>CELL2</TD></TR>
<TR><TD ROWSPAN=2>CELL3</TD></TR>
<TR><TD ROWSPAN=2>CELL4</TD></TR>
<TR><TD>CELL5</TD></TR>
</TABLE>

рПУНПФТЙН, ЮФП РПМХЮЙМПУШ.

уДЕМБЕН фБЛ рТЙ рПНПЭЙ тБНПЛ

<FRAMESET COLS="50%,50%">
<FRAMESET ROWS="50%,50%">
<FRAME SRC="cell.html">
<FRAME SRC="cell.html">
</FRAMESET>
<FRAMESET ROWS="33%,33%,33%">
<FRAME SRC="cell.html">
<FRAME SRC="cell.html">
<FRAME SRC="cell.html">
</FRAMESET>
</FRAMESET>

рПУНПФТЙН, ЮФП РПМХЮЙМПУШ.

уДЕМБЕН фБЛ рТЙ рПНПЭЙ NOFRAMES

<FRAMESET COLS="50%,50%">

<NOFRAMES>
<h1 align=center><blink>Frame ALERT!</blink></h1>
<p>
This document is designed to be viewed using <b>Netscape 2.0</b>'s
Frame features. If you are seeing this message, you are using
a frame <i>challenged</i> browser.
</p>
<p>
A <b>Frame-capable</b> browser can be gotten from
<a href=/>Netscape Communications</a>.
</p>
</NOFRAMES>

<FRAMESET ROWS="50%,50%">
<FRAME SRC="cell.html">
<FRAME SRC="cell.html">
</FRAMESET>
<FRAMESET ROWS="33%,33%,33%">
<FRAME SRC="cell.html">
<FRAME SRC="cell.html">
<FRAME SRC="cell.html">
</FRAMESET>

</FRAMESET>

рПУНПФТЙН, ЮФП РПМХЮЙМПУШ.

Corporate Sales: 415/937-2555; Personal Sales: 415/937-3777; Federal Sales: 415/937-3678
If you have any questions, please visit Customer Service.

Copyright © 1996 Netscape Communications Corporation

бЧФПТЙЪПЧБОЩК РЕТЕЧПД бОФПОБ мПВБУФПЧБ, ХЦ ЙЪЧЙОСКФЕ, ЕУМЙ ЮЕЗП ОЕ ФБЛ...
[оБЪБД ЛП ЧУСЛПК ПФОПУСЭЕКУС Л Web ДПЛХНЕОФБГЙЙ]


Frames -An Introduction

FRAMES: AN INTRODUCTION

уЙОФБЛУЙУ - пВЭЙЕ УМПЧБ

уЙОФБЛУЙУ - йНЕОБ, гЕМЙ (Target), Й хРТБЧМЕОЙЕ ПЛОБНЙ

ъБНЕФЛЙ П УПЪДБОЙЙ ТБНПЛ

у РПНПЭША ТБНПЛ, ЛПФПТЩЕ ТБЪДЕМСАФ Web УФТБОЙЮЛЙ ОБ ОЕУЛПМШЛП УЛТПММЙТХЕНЩИ ПВМБУФЕК, ЧЩ НПЦЕФЕ РТЕДУФБЧЙФШ ЙОЖПТНБГЙА Ч ВПМЕЕ ЗЙВЛПК Й РТЙСФОПК ЖПТНЕ. лБЦДБС ПВМБУФШ ЙМЙ ТБНЛБ ПВМБДБЕФ УМЕДХАЭЙНЙ ЧПЪНПЦОПУФСНЙ:

  1. еК НПЦЕФ ВЩФШ РТЙУЧПЕО ЙОДЙЧЙДХБМШОЩК URL, ВМБЗПДБТС ЮЕНХ Ч ОЕЕ НПЦЕФ ЪБЗТХЦБФШУС ЙОЖПТНБГЙС ОЕЪБЧЙУЙНП ПФ ДТХЗЙИ ТБНПЛ ОБ УФТБОЙГЕ;
  2. еК НПЦЕФ ВЩФШ РТЙУЧПЕОП йнс, РПЪЧПМСАЭЕЕ УУЩМБФШУС ОБ ОЕЕ ЙЪ ДТХЗЙИ URL, Й
  3. пОБ НПЦЕФ ДЙОБНЙЮЕУЛЙ ЙЪНЕОСФШ ТБЪНЕТ РТЙ ЙЪНЕОЕОЙЙ РПМШЪПЧБФЕМЕН ТБЪНЕТПЧ ПЛОБ. (юФП, Ч РТЙОГЙРЕ, НПЦЕФ ВЩФШ ЪБРТЕЭЕОП, ДМС ХЧЕТЕООПУФЙ Ч РПУФПСОУФЧЕ ТБЪНЕТБ ТБНЛЙ.)

чЩЫЕОБЪЧБООЩЕ УЧПКУФЧБ ДБАФ ОПЧЩЕ ЧПЪНПЦОПУФЙ:

  1. фЕ ЬМЕНЕОФЩ, ЛПФПТЩЕ УНПФТЕМШЭЙЛ ДПМЦЕО ВЩ ЧУЕЗДБ ЧЙДЕФШ, ФБЛЙЕ ЛБЛ ХРТБЧМСАЭЙЕ МЙОЕКЛЙ, ЛПРЙТБКФЩ Й ЪБЗПМПЧЛЙ, НПЗХФ ВЩФШ РПНЕЭЕОЩ Ч УФБФЙЮЕУЛХА, ЙОДЙЧЙДХБМШОХА ТБНЛХ. лПЗДБ УНПФТЕМШЭЙЛ ТБУУНБФТЙЧБЕФ site ЮЕТЕЪ "ЦЙЧЩЕ" ТБНЛЙ, УПДЕТЦЙНПЕ ЖЙЛУЙТПЧБОПК ПУФБЕФУС РПУФПСООЩН РТЙ УНЕОЕ УПДЕТЦЙНПЗП "ЦЙЧЩИ" ТБНПЛ.
  2. пЮЕОШ ХДПВОП ЙУРПМШЪПЧБФШ ТБНЛХ ДМС ПЗМБЧМЕОЙС. пДОБ ТБНЛБ НПЦЕФ УПДЕТЦБФШ ПЗМБЧМЕОЙЕ РТЙ ФЩЛБОЙЙ Ч УУЩМЛЙ ЛПФПТПЗП ТЕЪХМШФБФ ПФПВТБЦБЕФУС Ч ДТХЗПК ТБНЛЕ.
  3. вМБЗПДБТС ТБНЛБН УФБОПЧЙФУС ЧПЪНПЦОЩН РПУЩМБФШ ЪБРТПУЩ Й РПМХЮБФШ ТЕЪХМШФБФЩ ОБ ПДОПК Й ФПК ЦЕ УФТБОЙГЕ, ЕУМЙ УДЕМБФШ ПДОХ ТБНЛХ УПДЕТЦБЭЕК ЖПТНХ ЪБРТПУБ, Б ЧФПТХА - УПДЕТЦБЭЕК ТЕЪХМШФБФ.

оБЙМХЮЫЙН УРПУПВПН РПОСФШ ЛБЛ ТБВПФБАФ ТБНЛЙ - ЬФП РПУНПФТЕФШ ОБ ОЙИ. рПУНПФТЙФЕ уРЙУПЛ ЛПНРБОЙК, ЙУРПМШЪХАЭЙИ ТБНЛЙ юФПВЩ МХЮЫЕ РПОСФШ, ЮФП ЬФП ФБЛПЕ.

тБНЛЙ ПВУХЦДБАФУС Internet Engineering Task Force Й World Wide Web Consortium ОБ РТЕДНЕФ ЙУРПМШЪПЧБОЙС ЛБЛ УФБОДБТФОПЗП УТЕДУФЧБ Web.

Corporate Sales: 415/937-2555; Personal Sales: 415/937-3777; Federal Sales: 415/937-3678
If you have any questions, please visit Customer Service.

Copyright © 1996 Netscape Communications Corporation

бЧФПТЙЪПЧБООЩК РЕТЕЧПД бОФПОБ мПВБУФПЧБ, ХЦ ЙЪЧЙОСКФЕ, ЕУМЙ ЮЕЗП ОЕ ФБЛ...
[оБЪБД ЛП ЧУСЛПК ПФОПУСЭЕКУС Л Web ДПЛХНЕОФБГЙЙ]


How to target a link to a window

TARGETING WINDOWS

оПЧБС УРПУПВОПУФШ ДБЕФ БЧФПТХ ДПЛХНЕОФБ ОЕЛПФПТЩЕ ЧПЪНПЦОПУФЙ ХРТБЧМЕОЙС НЕУФПН РПСЧМЕОЙС ДБООЩИ РТЙ ЭЕМЮЛЕ УНПФТЙФЕМС РП УУЩМЛЕ Ч ДПЛХНЕОФЕ. пОБ НПЦЕФ РТЙНЕОСФШУС ПДЙОПЛП, Ч ДПЛХНЕОФЕ, ЛПФПТЩК НПЦЕФ ВЩФШ ОБЙМХЮЫЙН ПВТБЪПН РПУНПФТЕО РТЙ РПНПЭЙ НОПЦЕУФЧБ ПЛПО ЧЕТИОЕЗП ХТПЧОС (ОБВПТ ПЛПО УП УРЙУЛБНЙ ФЕН Й ПЛОП, ДЕНПОУФТЙТХАЭЕЕ УПВУФЧЕООП ФЕНХ), ОП ОБЙВПМШЫЙК ЬЖЖЕЛФ ДПУФЙЗБЕФУС РТЙ ЙУРПМШЪПЧБОЙЙ УПЧНЕУФОП У ОПЧПК УРПУПВОПУФША Netscap-Б РПЛБЪЩЧБФШ ТБНЛЙ.

лБЛ ЬФП ТБВПФБЕФ

тБЫШЫЕ, ЛПЗДБ УНПФТЕМШЭЙЛ ФЩЛБМ Ч УЧСЪШ, ОПЧЩК ДПЛХНЕОФ РПСЧМСМУС МЙВП Ч ФПН ЦЕ ПЛОЕ, ЛХДБ ПО ФЛОХМ, МЙВП (РП ЦЕМБОЙА ФЩЛБАЭЕЗП) Ч ОПЧПН ПЛОЕ. гЕМЕХЛБЪБОЙЕ ПЛПО РПЪЧПМСЕФ РЙУБФЕМА ДПЛХНЕОФПЧ РТЙУЧБЙЧБФШ ЙНЕОБ ПЛОБН Й РТЕДОБЪОБЮБФШ ДПЛХНЕОФЩ Л РПЛБЪХ ЧУЕЗДБ Ч ХЛБЪБОПН ПЛОЕ.

йНС РТЙУЧБЙЧБЕФУС ПЛОХ ПДОЙН ЙЪ ФТЕИ УРПУПВПЧ:

  1. дПЛХНЕОФ НПЦЕФ УПДЕТЦБФШ ОЕПВСЪБФЕМШОЩК HTTP ЪБЗПМПЧПЛ
    Window-target: window_name
    юФП ЪБУФБЧЙФ ДПЛХНЕОФ ЪБЗТХЪЙФШУС Ч ПЛОП У ОБЪЧБОЙЕН window_name, ЙМЙ ДБЦЕ УПЪДБФШ ФБЛПЕ ПЛОП, ЕУМЙ ПОП ОЕ УХЭЕУФЧХЕФ.
  2. уУЩМЛБ ОБ ДПЛХНЕОФ НПЦЕФ УПДЕТЦБФШ ХЛБЪБОЙЕ (ОБ СЪЩЛЕ HTML), РТЙУЧБЙЧБАЭЕЕ УУЩМЛЕ window_name. дПЛХНЕОФ, ЪБЗТХЦЕОЩК РП ФБЛПК УУЩМЛЕ ЧЕДЕФ УЕВС ФБЛ ЦЕ ЛБЛ ЙНЕАЭЙК Window-target ЪБЗПМПЧПЛ Ч 1-Н НЕФПДЕ.
  3. пЛОП, УПЪДБОПЕ ЧОХФТЙ ОБВПТБ ТБНПЛ (FRAMESET-Б) НПЦЕФ ВЩФШ РТПЙНЕОПЧБОП РТЙ РПНПЭЙ БФТЙВХФБ NAME Ч ФЬЗЕ FRAME. (УН. РТП тБНЛЙ)

лБЛ ЧЩЗМСДЙФ HTML

гЕМЕХЛБЪБОЙЕ Ч HTML ЧЩРПМОСЕФУС РТЙ РПНПЭЙ БФТЙВХФБ TARGET. ьФПФ БФТЙВХФ НПЦЕФ ВЩФШ ДПВБЧМЕО Л ТБЪМЙЮОЩН HTML ФЬЗБН, ДМС ГЕМЕХЛБЪБОЙС УУЩМПЛ, ЧИПДСЭЙИ Ч ФЬЗ. бФТЙВХФ ЙНЕЕФ ФБЛХА ЖПТНХ:
TARGET="window_name"

TARGET Ч ФЬЗЕ A.
ьФП ПЮЕОШ РТПУФП. сЛПТОЩК ФЬЗ (<A>) ПВЩЮОП ХЛБЪЩЧБЕФ УУЩМЛХ, ДПЛХНЕОФ РП ЛПФПТПК ОБДП ЪБЗТХЪЙФШ РТЙ ЕЕ БЛФЙЧБГЙЙ. дПВБЧМЕОЙЕ Л ФЬЗХ БФТЙВХФБ TARGET ЧЩЪЩЧБЕФ ЪБЗТХЪЛХ ДПЛХНЕОФБ Ч ХЛБЪБОПЕ ПЛОП. оБРТЙНЕТ:
<A HREF="url" TARGET="window_name">Targeted Anchor</A>
TARGET Ч ФЬЗЕ BASE.
йУРПМШЪХЕФУС ЛПЗДБ ЧЩ ИПФЙФЕ, ЮФПВЩ ЧУЕ (ЙМЙ ВПМШЫЙОУФЧП) УУЩМПЛ Ч ДПЛХНЕОФЕ ЙНЕМП ГЕМША ЛБЛПЕ-МЙВП ПДОП ПЛОП. фПЗДБ БФТЙВХФ TARGET ПТЗБОЙЪХЕФ ХЛБЪБОЙЕ ГЕМЕЧПЗП ПЛОБ РП ХНПМЮБОЙА. фБЛПЕ ХНПМЮБОЙЕ НПЦЕФ ВЩФШ, ЛПОЕЮОП, ПВПКДЕОП, ХЛБЪБОЙЕН ЙОПЗП ПЛОБ У РПНПЭША БФТЙВХФБ TARGET ЙОДЙЧЙДХБМШОП ДМС УУЩМЛЙ. оБРТЙНЕТ:
<BASE TARGET="window_name">
TARGET Ч ФЬЗЕ AREA.
дПЛХНЕОФ IETF Internet-Draft of Client-Side Image Maps пРТЕДЕМСЕФ ФЬЗ ДМС ПВМБУФЙ (<AREA>). ьФПФ ФЬЗ, ПФТБВБФЩЧБАЭЙКУС ОБ НБЫЙОЕ ЛМЙЕОФБ, ПРЙУЩЧБЕФ ОЕЛХА ПВМБУФШ ОБ ТЙУХОЛЕ, Й РТЙУЧБЙЧБЕФ ЕК УУЩМЛХ РП ЛПФПТПК ОХЦОП ЙДФЙ РТЙ ФЩЛБОЙЙ Ч ХЛБЪБОХА ПВМБУФШ ЛБТФЙОЛЙ. дПВБЧМЕОЙЕ БФТЙВХФБ TARGET Ч ФЬЗ AREA ЧЩЪЩЧБЕФ ЪБЗТХЪЛХ ДПЛХНЕОФБ РП УУЩМЛЕ Ч ХЛБЪБОПЕ ПЛОП. оБРТЙНЕТ:
<AREA SHAPE="shape" COORDS="x,y,..." HREF="url" TARGET="window_name">
TARGET Ч ФЬЗЕ FORM.
фЬЗ FORM ПВЩЮОП РПЛБЪЩЧБЕФ ТЕЪХМШФБФ ЪБРТПУБ ЙЪ ЖПТНЩ Ч ФПН ЦЕ ПЛОЕ, ЮФП Й УБНБ ЖПТНБ. дПВБЧМСС TARGET НЩ НПЦЕН РЕТЕОБРТБЧЙФШ ТЕЪХМШФБФ Ч ХЛБЪБОПЕ ПЛОП. оБРТЙНЕТ:
<FORM ACTION="url" TARGET="window_name">

дПРХУФЙНЩЕ ЙНЕОБ Ч TARGET

йНС ПЛОБ, ХЛБЪЩЧБЕНПЕ Ч БФТЙВХФЕ TARGET ДПМЦОП ОБЮЙОБФШУС У ВХЛЧЩ ЙМЙ ГЙЖТЩ, ЮФПВЩ ВЩФШ РТБЧЙМШОЩН. чУЕ ДТХЗЙЕ (ОЕРТБЧЙМШОЩЕ) ЙНЕОБ ЙЗОПТЙТХАФУС.
йУЛМАЮЕОЙЕ: уХЭЕУФЧХАФ НБЗЙЮЕУЛЙЕ ЙНЕОБ, ОБЮЙОБАЭЙЕУС У УЙНЧПМБ "РПДЮЕТЛЙЧБОЙЕ".

нБЗЙЮЕУЛЙЕ ЙНЕОБ Ч TARGET

чУЕ ЬФЙ ЙНЕОБ ОБЮЙОБАФУС У УЙНЧПМБ "РПДЮЕТЛЙЧБОЙЕ". мАВПЕ ЙНС ПЛОБ, ОБЮЙОБАЭЕЕУС У РПДЮЕТЛЙЧБОЙС Й ОЕ ЧИПДСЭЕЕ Ч ОЙЦЕУМЕДХАЭЙК УРЙУПЛ, НБЗЙЮЕУЛЙН ОЕ СЧМСЕФУС Й РПРТПУФХ ЙЗОПТЙТХЕФУС.

TARGET="_blank"
рТПУЙФ ДПЛХНЕОФ ЪБЗТХЪЙФШУС Ч ОПЧПЕ, РХУФПЕ ПЛОП. пЛОП РПМХЮЙФУС ОЕЙНЕОПЧБОПЕ.
TARGET="_self"
рТПУЙФ ДПЛХНЕОФ ЪБЗТХЪЙФШУС Ч ФП ЦЕ ПЛОП, ЛПФПТПЕ УПДЕТЦЙФ ФЩЛОХФХА УУЩМЛХ. рПМЕЪОП ДМС ПВИПДБ ЗМПВБМШОП РТЙУЧПЕООПЗП ГЕМЕЧПЗП ПЛОБ (Ч ФЬЗЕ BASE.)
TARGET="_parent"
чЩЪЩЧБЕФ ЪБЗТХЪЛХ ДПЛХНЕОФБ Ч ПЛОП - ОЕРПУТЕДУФЧЕООПЗП ТПДЙФЕМС ФЕЛХЭЕЗП FRAMESET-Б тБВПФБЕФ ФБЛЦЕ ЛБЛ "_self" ЕУМЙ Х ДПЛХНЕОФБ ОЕФ ТПДЙФЕМС.
TARGET="_top"
чЩЪЩЧБЕФ ЪБЗТХЪЛХ ДПЛХНЕОФБ Ч РПМОПЕ ПЛОП. дЕКУФЧХЕФ ФБЛЦЕ ЛБЛ "_self" ЕУМЙ ДПЛХНЕОФ ХЦЕ Ч РПМОПН ПЛОЕ. рПМЕЪОП ДМС ТБЪВЙЧБОЙС ЧМПЦЕООЩИ FRAME РТПЙЪЧПМШОПК ЗМХВЙОЩ.

пРЙУБОЙЕ FRAMESET-Б Й ФЬЗБ FRAME, УН. рТП тБНЛЙ.

Corporate Sales: 415/528-2555; Personal Sales: 415/528-3777
If you have any questions, please visit Customer Service.

Copyright © 1996 Netscape Communications Corporation

бЧФПТЙЪПЧБОЩК РЕТЕЧПД бОФПОБ мПВБУФПЧБ, ХЦ ЙЪЧЙОСКФЕ, ЕУМЙ ЮЕЗП ОЕ ФБЛ...
[оБЪБД ЛП ЧУСЛПК ПФОПУСЭЕКУС Л Web ДПЛХНЕОФБГЙЙ]


Teleport Pro Messages

 .

http://home.netscape.com/comprod/products/navigator/version_2.0/frames/frame_users.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/misc/bottom.map: This file was not retrieved by Teleport Pro, because it did not meet the project's file type specifications.

.

http://home.netscape.com/assist/customer_service/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/misc/contact_info.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www-geocad.nstu.nsk.su/~tony: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www-geocad.nstu.nsk.su/koi/Docs/default.htm: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.ics.uci.edu/pub/ietf/html/draft-seidman-clientsideimagemap-01.txt: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/search/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/ads/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/netstore/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/toc.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/comprod/mirror/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/escapes/galleria.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/feedback/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.netscape.com/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www-geocad.nstu.nsk.su/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.